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Introduction
The groundwater flow model GFLOW is operationally most efficient if the number of analytic elements is kept relatively low. Consequently, when modeling
large regional aquifers it is preferable to subdivide the domain in smaller “hydrological units” that are to be modeled independently. However, each sub-domain
or hydrologic unit must be surrounded with appropriate “farfield” features (hydrologic features that are just outside the area of interest) in order to obtain
a valid groundwater flow solution. Those farfield hydrologic features are, of
course, nearfield features for a model of the hydrologic unit to which they belong. To avoid multiple entries in GFLOW of the same hydrography (stream,
lakes, etc.) GFLOW has been provided with a set of tools to manage the creation and modeling of hydrologic units.
The idea is to create a database of line-sink files and inhomogeneity files that
cover a large region, much larger than is practical to include in a single groundwater flow model. These line-sink and inhomogeneity files are then selectively
combined to form local groundwater flow models. Model data improvements in
these local models are recycled back into the database by exporting the updated
line-sink and inhomogeneity files to disk, overwriting the existing files.
Hydrologic Units in GFLOW are based on the “Federal Standards for Delineation of Hydrologic Unit Boundaries,” which recognizes 6 levels of hydrologic
units (USGS, 2001). The lowest level, smallest unit, is a “sub-watershed,” typically between 10,000 and 40,000 acres in size and identified by a 12-digit code.
Sub-watersheds, therefore, are also referred to as 12-digit HUCs, where “HUC”
stands for Hydrologic Unit Code. When referencing a “hydrologic unit” in
GFLOW a 12-digit HUC is implied.
A modeling project will be constructed by combining the streams and lakes
in several adjacent HUCs into the project. This is done by reading in an HUC
file that contains the names of the files with line-sinks that define the streams
and lakes in a HUC. The HUC file also includes the names of the relevant
inhomogeneity domains. These line-sink files and inhomogeneity files have been
generated earlier in GFLOW. The HUC file that defines a project must be made
by the modeler, possibly with use of a GIS system. The process of creating linesink and inhomogeneity files, exporting them, and reading them back in to form
a modeling project is described below.
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Defining Hydrologic Unit Boundaries
Hydrologic Units in GFLOW are used to manage the stream and lake features
by writing them to a file or reading them from a file. Note: Hydrologic Units are
standard domains defined by the USGS based on watersheds and subwatersheds
of stream networks. These domains are given a code consisting of a sequence
of two digit numbers that refer to the location and hierarchy of the domain.
Because of this coding, an hydrological domain is also referred to as an “HUC”
for Hydrological Unit Code. To define these domains in GFLOW proceed as
follows.
Open the project and include background maps that clearly show the hydrological unit boundaries. Use the Add a Hydrologic Unit Boundary option on the
Model menu to create the HUC domains. It is recommended to use the actual
HUC (hydrologic unit code) as the name of the domain. Select an easy recognizable color that does not coincide with the colors of analytic elements to be
introduced later. In an example project file “HUCdemo.gfl” the HUC boundaries are dark orange. You must make closed domains, hence adjacent HUC
domains will have partly coinciding domain boundaries. The domain boundaries may be crude in areas where there are no nearby surface waters. What is
important is that the domain boundaries properly include or exclude the relevant streams and lakes. You may give a new domain boundary a different color
to track its entry on top of adjacent domain boundaries that have been entered
before. You can later select the domain (double click) and redefine its color.
The Hydrologic Unit Boundaries may be made visible or invisible by selecting View>Hydrologic Unit and checking or unchecking the Hydrologic Unit
Boundary.

Defining streams, lakes, and inhomogeneities
Inhomogeneities are to be entered that define the local aquifer properties and
recharge rates. Follow the guidelines in the GFLOW Help system to properly
define these domains. Inhomogeneity domains do not have to coincide with
hydrologic unit domains; they should be defined as required by the hydrogeology
of the area. These inhomogeneity domains will be written to disk in individual
files (one per domain) and read back as needed to define a modeling project.
The streams and lakes inside each domain are represented by line-sink strings
in the same manner as for a regular model. The line-sink strings should not cross
into an adjacent HUC. All streams are to be treated as near-field and streams
and tributaries are to be organized in a single stream network for the HUC. The
stream network should end at the point where the main stream exits the HUC.
If a stream enters the HUC it should be given an “end inflow” on the “Routing
tab” of the “Linesink Properties” dialog. Initially this “end inflow” should be
estimated from field data, but during successive modeling of all of the HUCs as
part of the nearfield, the “end inflow” values will automatically become updated
to those that follow from the modeling results, as is explained below.
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Passing stream flow from one HUC to the next.
Initially, the stream flow in all streams will be zero. After a HUC has been part of
a model as a nearfield domain, a stream flow solution will exist and the stream
flow will generally be non-zero. If that same HUC is included in a different
model as a farfield domain, the stream flow at the end of the exiting stream will
be given as “end inflow” to the nearest receiving stream section in one of the
nearfield domains. This occurs automatically upon loading the “filename.huc”
file that defines the project. Note: this procedure relies on the tacit assumption
that a stream that exits a domain does have a non-zero stream flow. If the
exiting stream flow is indeed zero, the “end inflow” of the receiving stream is
not updated. However, an HUC with no exit stream flow seems unlikely; it
would have little impact on the groundwater flow regime to begin with. In a
special case where this does occur, the user has to intervene and manually set
the “end inflow” of the receiving stream to zero (if it is not zero already).

Defining FarField Boundaries
Each Hydrologic Unit in GFLOW must have a “farfield boundary” in order
for that Hydrologic Unit to serve as a nearfield domain in a modeling project.
Those HUCs that are not, or not yet, used as a nearfield domain do not (yet)
have to have a farfield boundary defined. In the project file “HUCdemo.gfl”
only HUC - 08 is used as a nearfield domain and only this HUC has been given
a farfield boundary. To enter a farfield boundary for an HUC proceed as follows.
Left-click near a vertex inside the HUC for which you want to add the farfield
boundary. Make sure the HUC boundary is selected (highlighted). Next select
Add a FarField Boundary on the Model menu. A default name is shown on the
“Domain Properties” dialog, which cannot be changed. Select an appropriate
color for the farfield boundary. In the project file “HUCdemo.gfl” the farfield
boundary has been given a light green color. The farfield boundary should include all streams and lakes in adjacent HUCs that are to be treated as nearfield
(together with the features in the HUC for which the farfield boundary is entered) during a modeling project. The purpose of this boundary is to ensure
that streams and lakes immediately outside the HUC that serves as a nearfield
domain are also treated as nearfield features. Consequently, part of the streams
and lakes in the surrounding “farfield HUCs” are treated as nearfield and part
as farfield. It is sufficient to have the start of a line-sink string inside the farfield
boundary in order to have that entire string treated as nearfield.

Defining Model Boundaries
A Hydrological Unit in GFLOW may optionally have a “model boundary.” This
“model boundary” must occur outside the ”farfield boundary” of the HUC and
is intended to limit the streams and lakes from the surrounding farfield HUCs
that are included in a project. All line-sink strings that have their starting
3

points outside of the “model boundary” will be excluded from a model that
includes the current HUC as a nearfield domain. The purpose of the “model
boundary” is to reduce the total number of analytic elements in a model. The
elements (line-sink strings) that fall outside the model boundary are assumed
unnecessary to serve as farfield for a model with the current HUC as nearfield.
To add a “model boundary” select the HUC boundary, and click on
Model>Add Model Boundary. Enter a polygon outside the farfield boundary
for the current HUC and so that the starting vertices of all line-sink strings to
be excluded are outside the polygon.

Exporting HUCs and Inhomogeneities
The line-sinks (in each hydrologic Unit) and the inhomogeneity domains can be
exported to “*.lss” and “*.inh” files, respectively. These files can later be combined into a modeling project by defining them in an “HUC” file and importing
that file into GFLOW. It is recommended that a model solution is attempted
before writing the data to the respective files. This will ensure that no basic
errors occur in the data. To export these files proceed as follows.
To export a Hydrologic Unit, select the hydrologic unit to be exported by
left-clicking near a vertex on the inside of the appropriate HUC boundary. Once
the boundary is highlighted, select Tools>Export>Hydrologic Unit and specify
an appropriate filename. It is recommended to use the HUC code for the domain
as the filename. The file “name.lss” will be written to disk with all the line-sink
information and the farfield boundary (if present).
To export an Inhomogeneity, select the inhomogeneity to be exported by leftclicking near a vertex on the inside of the inhomogeneity boundary. Once the
inhomogeneity is highlighted, select Tools>Export>Inhomogeneity and specify
an appropriate filename. It is recommended to use the label for the domain as
the filename. The file “name.inh” will be written to disk and includes all the
inhomogeneity domain information.

Creating an *.HUC file
A modeling project may be defined with an *.huc file in which the hydrologic
units and inhomogeneities are defined for the project. The file has the following
format:
Path "C:\thepath"
nearfield
filename1.lss
filename2.lss
etc.
farfield
filemame3.lss
filename 4.lss

4

etc.
inhomogeneities
filename5.inh
filename6.inh
etc.
The “path” command defines the folder where the *.lss and *.inh files are
to be found. The nearfield may be formed by one or more hydrologic units,
but in the example file “project1.huc” only one hydrologic unit is defined as
nearfield. If a file is listed under the “nearfield” heading it must contain a
farfield boundary. The nearfield domains must be surrounded by hydrologic
units that serve as farfield. These hydrologic units are listed under the “farfield”
heading. Finally, all inhomogeneity domains that affect the nearfield and the
farfield domain defined by the files in the *.huc file must be listed under the
“inhomogeneities” heading.
Note: It is important to first define the nearfield domain(s) and after that
the farfield domains. The reason for this is that the line-sinks strings in the
farfield domains are modified or ignored based on whether they are inside the
farfield boundaries or outside the model boundaries of the nearfield domains,
respectively.

Creating a modeling project by use of a *.HUC
file
To create a GFLOW project using a *.huc file proceed as follows.
Start GFLOW and create a new project. Select the proper basemap units
and computational units and add the proper basemaps for the model area. Next
set the background aquifer properties on the Model>Settings>Aquifer tab, realizing that the inhomogeneity domains may redefine these in the model area. Also
select appropriate contouring settings and, for now, uncheck “Compute Particle
Paths” on the Contouring and Tracing tabs, respectively. On the Solver tab
select sufficient iterations (between 5 -10, depending on model size) and check
both “Conjunctive Surface Water - Groundwater Solution” and “Store decomposed matrix on disk for faster solve.” The latter option should be unchecked
if line-sinks with resistance keep having large errors after many iterations. You
are now ready to import the model data.
Select Tools>Import>Hydrologic Unit and open the proper *.huc file. After
the line-sinks and inhomogeneities are read in, you may solve the groundwater
flow problem and make improvements on the model as needed. The hydrologic
unit boundaries and farfield boundaries may be hidden by unchecking them on
View>Hydrologic Unit. You can freely add delete or modify line-sink strings
and inhomogeneities. Keep in mind, however, that only one stream may enter
and only one stream may leave a hydrologic unit. You may also update the
“end inflow” for the incoming stream using the streamflow at the end of the
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upgradient hydrologic unit as obtained from a model in which that upgradient
hydrologic unit was a nearfield domain.

Updating *.lss and *.inh files
Once a modeling project is completed the line-sinks in the nearfield hydrologic
unit or units may be written to disk (overwriting the existing files) in order to
update (enhance) the data base of GFLOW HUC line-sink files. Similarly, you
may write new or updated inhomogeniety domains back to disk. You will not
be allowed by GFLOW to write line-sink files for HUC domains that serve as
farfield in your project.
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