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Note 1: For many of the menu options there is a short cut on the tool bar. At some point, after 
having loaded a project file, you may slowly move the mouse cursor over the various tool bar 
buttons and observe their functions (popup text).  You can use these short cuts as alternatives 
to the menu options described in the tutorial or elsewhere in the Help system. 
  
Note 2: The procedures outlined in the tutorial are implemented in the project file example.gfl, 
which may be inspected for further clarification.  
  
Note 3: This tutorial illustrates only the most fundamental features of GFLOW. The user is 
encouraged to consult the on-line Menus section and read the documents (in PDF format) 
provided in the <user> application data folder on the C: drive in the subfolder GFLOW. Note: A 
precise path cannot be indicated as it differs per Windows version. These PDF documents can 
also be accessed from the Help menu.  
Setting Up a Project 
  
For the purpose of this tutorial you are provided with eight example vector graphics maps in the 
area of Vincennes, Indiana*. The vector graphics maps have the extension "bbm" and contain 
various layers of information in four areas surrounding the city of Vincennes. Maps with "hyf" in 
the name contain the "hydrography": streams, lakes, etc. Maps with "rdf" in the name contain 
the roads, with "rrf" in the name the rail roads and with "mtf" in the name some miscellaneous 
transportation features (power lines, pipelines, etc.).  
The maps are to be found in the <user> documents folder on the C: dive in the subfolder 
GFLOW projects. Note: A precise path cannot be provided as it differes with Windows versions. 
  
As a rule, when setting up a project, you must organize the relevant map files in your working 
folder. This is any user accessible folder in which you like to organize the files related to your 
modeling project. I recommend that you make this a subfolder of the GFLOW projects folder 
mentioned above. All these maps must be referenced to the same coordinate system, e.g. 
Universal Transverse Mercator (UTM) or State Plane, and must be in the same units - either 
meters or feet.  Users in the USA may obtain digital versions of the USGS DLG files by 
downloading these from the EPA website: 
  
https://www.epa.gov/exposure-assessment-models/whaem2000-bbm-files-us 
  
These maps are downloaded as self-extracting zip files (xxxxx.exe), which rmay require the "run
anyway" option to overrule Windows' security block. NOTE: EPA is in the process of converting 
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the16-bit self-extracting files into 64-bit ones. If your xxxxx.exe fails to run, then simply right-
click on it and select WinZip to force an extract of the maps. 
  
You should also have completed a literature survey to obtain estimates for the elevation of the 
aquifer bottom, elevation of the aquifer top, hydraulic conductivity, effective aquifer porosity, and 
areal recharge rate due to precipitation. For the purpose of this tutorial these parameters will be 
given to you when discussing how to enter them into GFLOW. 
  
*Note: You can also use alternative vector format files or raster format files, as indicated in the 
manual under Menus,  Project Menu. We will not illustrate the use of these files in this tutorial, 
however. 
  
Main Menu            Previous            Next   
Selecting Base Map Files 
  
Start GFLOW, click on the left most icon (blank sheet) or select New DatabaseÖ  from the 
Project menu. In the dialog box for the project file name, navigate to your working directory (for 
this tutorial \GFLOW projects\example) and enter the filename demo.gfl, click Open.  
  
The "New Database Wizard" will prompt you for a project description and the units associated 
with the input data. GFLOW requires consistent units, these are either meters and days or feet 
and days. For instance, if you select meters and days, the hydraulic conductivity must be 
entered in meters per day and a well pumping rate must be entered in cubic meters per day. 
However, the distance units associated with your base maps are specified independently from 
the "Units for Computations". In this way, you can accept base maps in meters (e.g. UTM 
coordinates), while using feet and days for all other input data or vice versa. The GUI will 
convert the base map units to the computational units when forwarding data to the solver, which 
works in consistent units throughout. We must select meters for the "Distance Units in Base 
Map Files", because the base maps provided with this tutorial are in UTM coordinates, while we 
will select feet and days as the "Units for Computations". The box "Project Description" allows 
you to keep track of some essential properties of this particular database, e.g. "Run with high 
recharge rate and low conductivity".  
  
Important: You cannot select the "Distance Units in Base Map Files" freely; they must 
correspond to the units associated with your base map files! 
  
After you made your selections click on Create Database.  
  
The next window is the Project Settings dialog. The window "Currently Used Base Maps" will be 
empty at this point. Click on Add Map to display the available  base map files. For this tutorial 
we will assume that .bbm files are used for base maps (contain USGS DLG maps). Users 
outside the USA may substitute the references to .bbm files elsewhere in this manual (not here 
in the tutorial) to the relevant file format for their project area (e.g. DXF, shapefile, tiff, etc.). 
Click on the first *.bbm file name and click on Open. Repeat this procedure for all *.bbm files 
you want to include. In most cases you have only copied the .bbm files to the working directory 
that need to be included. You may select them all at once by left-clicking on the first file and 
while holding down the Shift key left-click on the last file. After they all are highlighted click Add 
Map. All base maps should be displayed in the box "Currently Used Base Maps". Now click OK. 
The maps will be loaded and plotted in the graphics window.  
  
Note: You can later select and deselect base map files for display on the View menu, selecting 
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Base Maps.. and Vector Graphics (or Raster Graphics if present). If you select View>Base 
Map..>Select BBM Group, then map boxes are drawn around each group of *.bbm files. A left-
click inside a box brings up a Group of BBM Maps file management dialog box that let's you 
select, deselect or delete the group of files that make up the vector graphics image inside the 
selected map box. You can also select a single file or sub set of files by clicking on the others to 
deselect them (not highlighted). Terminate the BBM management mode by clicking on the 
button Done Editing BBM Groups.  
  
Note:  A Help file for the Group of BBM Maps dialog box can be obtained by pressing F1.  The 
F1 key will also display help files for other dialog boxes. 
  
Note: You may find superimposed on the map a so-called editor grid. You may toggle this off or 
on by clicking on the View menu and deselecting or selecting Show Editor Grid under the Base 
Map.. option. 
  
Main Menu            Previous            Next  
Annotating the Base Map 
  
Zoom out using Windows>Zoom Extents or the Zoom extents button on the tool bar. The 
curved double blue line is the Wabash River in southwestern Indiana. The big city just below the 
center is Vincennes. Click on the button Zoom to Window, place the cursor to the upper left of 
the city and, while holding down the left mouse key, drag a box over the city and its 
surroundings.  
  
It is useful to annotate your base map with estimated surface water elevations at those streams 
that you intend to include in the model (represent by line-sinks). This may be done by use of 
71/2 minute USGS topographic maps as follows. (Refer to the second note below if you don't 
have these maps available). 

Find the intersection of a surface elevation contour line (brown line) with the stream you 
want to annotate.  
Estimate the location of that point on the map on your screen, click on Add text on the 
Edit menu, move the text cursor to the proper location on the stream and click the left 
mouse button.  
Type the contour elevation in the dialog box, check the Hydrography Label option, and 
click OK.  
The label appears on the map and the cursor reappears.  
Repeat this procedure for all contour lines and all streams you intend to include in the 
model.  

  
It is often sufficient to add these hydrography labels near the map boundaries and near 
confluences of streams. When creating line-sink strings you will only be prompted for a head at 
the start of the string and at the end of the string. The program will interpolate between these 
heads. 
  
Note 1: It is important to enter all these water levels as Hydrography Labels, so that you can 
select them on the View menu as a map layer when creating line-sinks and make them 
disappear when done. This way the map on your screen is not cluttered with labels when 
modeling. 
  
Note 2: An example annotated base map is provided in the project file example.gfl. You may 
open (Open Database on Project menu) this project file and activate the hydrography labels 
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(View>Hydrography Labels), and print the base map for guidance in marking up your map in 
demo.gfl. Prior to printing you may need to zoom out to include all of the labels. Hence, as an 
alternative to using the contour lines on USGS topographic maps, you may use the printout of 
hydrography labels from the example.gfl project as guidance to practice entering 
hydrography labels.  
  
Note  3: The project file example.gfl contains a (crude) representation of the hydrogeology in 
the Vincennes, Indiana area. By no means does it represent a complete and realistic 
conceptual model of the aquifer system. It is provided here merely to provide some guidance in 
setting up a project. For a more complete description of groundwater flow modeling near 
Vincennes, Indiana, see Chapter 6, section 6.1 of Analytic Element Modeling of Groundwater 
Flow, H. M. Haitjema, Academic Press, 1995. 

  
Main Menu            Previous            Next  
Entering Aquifer Properties 
  
Select Settings on the Model menu and click on the Aquifer tab. Enter the following data: 
  
Base Elevation = 330 
Thickness = 100 
Hydraulic conductivity = 350 
Porosity =0.2 
  
Click OK to enter these values in the database. 
  
Note: We will not use the Add Salt Water Interface option for this tutorial, leave it unchecked. 
  
Main Menu            Previous            Next  
Adding Recharge 
  
Recharge is introduced by use of an inhomogeneity domain. First zoom out so that the entire 
model area, including the far-field, is depicted in the graphics window. Click on Elements, New 
and Inhomogeneity. Type "regional recharge element" in the Label box. Check the box "Change 
Recharge from Default" and enter 0.0032 in the box for Added Recharge Rate. Do not enter 
data in any other box and leave the Change hydraulic conductivity from default, Change 
porosity from default and Change base elevation from default boxes unchecked. Click OK and 
draw a rectangular box around the model area, including the far-field. Four large line elements 
are sufficient. Simply move the cursor to the corners of the desired box and click. After clicking 
on the last corner add a right-click and the box will be completed. Important: Do not move the 
cursor to the starting point and left-click, this would put two vertices on top of each other and 
cause computational problems. 
  
If necessary, you can modify the recharge rate locally by defining additional inhomogeneities 
with only an Added Recharge Rate specified. Nested inhomogeneities with recharge are 
additive, the sum of the recharge rates are applied to the aquifer. At this point in our exercise 
we will work with only this one recharge rate for the entire model domain. 
  
Note: Inhomogeneity domains may have common boundary sections, for instance to make a 
mosaic of different aquifer properties and recharge rates. Common boundary sections must 
have coinciding vertices, not just vertices that are close! To achieve this, you must hold down 
the CTRL key when placing a vertex on top of another vertex of another domain while left-
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clicking the mouse. This will ensure that the vertices will truly coincide. 
  
Main Menu            Previous            Next  
Creating Analytic Elements 
  
Line-sinks 
To create line-sinks, select New on the Element menu and click on Linesink. We will first enter 
line-sinks for Wabash River. Follow these steps: 
      1.  Type "Wabash River west side" in the Label box. You should be on the tab sheet labeled 
            General and the radial button for Head-Specified should be checked.  

Enter the Starting Head. This is the water level in the stream at the start of the line-sink 
string you intend to create. In our case we will start our string just above the city of 
Vincennes, the head is 400 feet according to our hydrography labels. Type 400 in the 
box. 
For now, enter 0 for Resistance, 500 for Width and 10 for Depth on the Linesink String 
properties dialog. We will later revisit these values. 
Under Linesink Location check the radio button "Along surface water boundary" 
Click OK. 
Move the cursor to the point on the stream where the 400 label is located. Click the left 
mouse button to enter the first vertex.  
Move the cursor following the river downstream along the western river boundary to the 
south and click the left mouse button again, creating the next vertex. Continue this 
procedure until you want to end the string.  
End the string with a left click, followed by a right click, where the 393.7 ft label occurs, in 
a meander south west of Vincennes. The dialog box reappears.  
Type the Ending Head, which is 393.7 ft. Click OK to complete the definition of this line-
sink string.  
Repeat this procedure, but now position the line-sinks along the eastern river boundary. 
Use "Wabash River east side" as the label. 

At the center of each line-sink in the string GFLOW will assign a head, which results from a 
linear interpolation of the starting head and ending head along the line-sink string. 
Important: You should always enter line-sink strings from the up gradient end of the 
stream section to the down gradient end. This provides for consistency when querying the 
model results along a string.  
  
Continue to create line-sink strings, using small line-sinks in the near-field and larger ones in 
the far-field . None of the remaining streams require a double linesink string as done for 
Wabash River. Try to keep the total amount of line-sinks below 200 for this initial run.  
For linesink strings in the nearfield leave the box Treat as Farfield unchecked and select the 
radio button Along stream centerline. Select 0 for the resistance and 5 for the depth parameter. 
Enter an estimate for the stream width for the Width parameter, say between 5 and 50 feet..  
For linesink strings in the farfield check the box Treat as Farfield, which will set the Resistance, 
Width and Depth parameters to zero. Consequently, a line-sink string should either be entirely 
in the far-field or entirely in the near-field. Wabash River, therefore, should be modeled with at 
least four line-sink strings: a far-field string to the south-west of Vincennes (placed at the center 
of Wabash River), two near-field strings near Vincennes (which we introduced in the step by 
step procedure above), and a far-field string to the north of Vincennes, again along the center of 
the river. 
  
Note: The map you just printed earlier (see Note 2 of Annotating Base Map) from the project file 
example.gfl has line-sinks on them: the solid black line strings (dark green, blue or pink on a 
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color print) with solid squares at the line-sink string starting points (vertices) in case the string is 
selected (clicked on with left mouse button). You may use this line-sink layout as some 
guidance for your own line-sink creation. The line-sink strings in example.gfl are only a first 
rough setup of the model. You may refine the model at a later time. Notice in example.gfl that 
the line-sink vertices along Wabash River are closer together opposite the well. This has been 
done to allow the groundwater inflow or outflow along Wabash River to vary due to the effect of 
the well. Remember that each line-sink has a constant sink density, hence multiple line-sinks 
are necessary to approximate any infiltration or exfiltration variations along Wabash River 
opposite the well by a step function of sink densities. When looking on the screen, also observe 
that the line-sinks near the well field (nearfield) are dark blue, while the line-sinks in the farfield 
are dark green. Always inspect your model to make sure no dark blue line-sinks occur in the 
farfield (dark green line-sinks are OK in the nearfield). 
  
  
Wells 
To create a well, point at New on the Element menu and click on Well. Follow these steps: 

Move the cursor to the location of the well and click the left mouse button. You may 
place the well to the west of Vincennes near the Wabash River, see the printout of the 
map of example.gfl. A marker for the location of the well is added to the base map 
and a dialog box appears.  
Type "wellfield" in the Label box. You should be on the tab sheet labeled General and 
the radial button Discharge-Specified should be checked. The well should be at UTM 
coordinates x=452650, y=4280665. You may adjust the coordinates by typing over 
them.   
Type the well pumping rate 350000 in the Discharge box and the well radius 4 in the 
Radius box.  
Since we intend to create capture zones for this well we should define some particle 
tracking starting points. Select the tab sheet labeled Other.  
Check the box for Trace particles from well. 
Type the desired number of path lines, e.g. 16, in the Number of particles box. 
Type the aquifer base elevation 330 in the Starting elevation box.  
You may also enter a Setback Radius, e.g. 100 feet. A dashed circle will be drawn 
around the well that may be a sanitary setback. Or, you may enter a "fixed radius 
wellhead protection zone," for instance 3000 feet. 
Click OK to add the well to the database. 

  
Main Menu            Previous            Next  
Running the Model 
  
Before running the groundwater model you may set some model output options. These include 
the generation of potentiometric contours, path lines from wells, path lines from isolated points, 
and heads at test point. For our initial model run we will only specify the generation of 
potentiometric contours. 
Select Model>Settings>Contouring and check the box Compute Contours.  Make sure that the 
option Heads is checked (default). You may keep the grid resolution (grid of points where heads 
will be calculated) at the default Coarse for now.  Define the Minimum Contour level (330), the 
Maximum Contour level (450), and the Contour Interval (2) and click OK to leave the Model 
menu.  Now click on Model>Solve, a DOS box appears with some progress indicators for the 
solution process. When the solver is done the base map reappears with an overlay of 
potentiometric contours (blue lines) that are labeled with their potentiometric head elevations.  
On top of the map is a text file Message.log that contains a runtime log of the Solver. Make sure 

1. 

2. 

3. 

4. 

5. 
6. 
7. 
8. 

9. 

Page 6 of 15Tutorial

4/8/2016file://C:\Documents and Settings\Administrator\Local Settings\Temp\~hh6292.htm



all % errors in boundary conditions are at least smaller than 1% and close the file to view the 
graphical model results. 
  
Note: The heads in the far-field may exceed 450 feet, but will not be plotted above that level 
since we limited the maximum contour level to 450 (to avoid clutter). You may want to 
experiment with different contour settings. 
  
Main Menu            Previous            Next  
Check the Solution Integrity 
  
There are 3 different ways in which you can check the accuracy of the groundwater flow 
solution. These are: 
  

Select Model>View Model Run FilesÖ >Runtime Message File, which will open 
the message.log file from the Solver. This is the file that was displayed on top of the graphics at 
the end of the Solver run and contains a report on the maximum errors detected at boundary 
conditions. For a description of these errors click here. 

Select Model>View Results Table, click on View and on Line-sinks. Look in the table to 
ensure that the SpecifiedHead (specified head from water levels) and CalculatedHead 
(head calculated by model) for all line-sinks are nearly the same. You may also check the 
Error column to identify unacceptable differences.  This ensures a solution that meets the 
boundary conditions, at least at the line-sink centers. Also in the table is a column with 
the Discharge for each line-sink, which is the extraction rate of the line-sink (or sink 
density) per unit length in square feet per day or square meters per day.  
There is also a quick graphical way to verify the accuracy with which the boundary 
conditions at the line-sink centers are met. Select View>Results OverlayÖ  and check the 
box in front of Display Graphical Results Information. Next select the Percent Error from 
the options menu. Note that the minimum and maximum errors are displayed and used 
as a scaling parameter. The Percent Error will be displayed as a line thickness, whereby 
the thickness of the line is proportional to the magnitude of the error. Also note the other 
options on the menu, which you may like to use later during your modeling activities. 

  
The check on boundary conditions (comparing specified and modeled heads) is only relevant 
after the solver has been run with new aquifer parameters or analytic element data. You do not 
have to perform this check, for instance, when regenerating contours or path lines based on the 
same solution. 
  
Main Menu            Previous            Next  
Displaying Results 
  
Different map overlays may be specified on the View menu: e.g. Elements, Contours, and Path 
lines. If contours are not displayed at this time, check the Contours option on the View menu 
and verify that the contour levels match the specified heads at streams, at least approximately.  
  
Testpoints 
In order to compare the calculated heads with observed heads it is convenient to specify "Test 
points" at which you specify observed heads, for instance, heads measured at piezometers or 
static water levels reported for domestic and industrial wells. Water levels in gravel pits may 
also be used as test points.  

Test points are added as follows: 
Select Add Test Point on the Model menu.  
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Move the cursor to the estimated position of the test point on the screen and click the left 
mouse button.  
Select the radio button for Piezometers (default) and type a label and the observed head 
(e.g. static water elevation on a well log) in the dialog box. Note: the other two options 
Gages and Lake Stages are for more advanced use and should be ignored for now. 
Click OK to add this to the database.  
Repeat the procedure for other test points.  

  
For the purpose of this tutorial you may make up test points by selecting some arbitrary 
locations and estimating the heads by use of the potentiometric contours. To simulate reality 
select some heads a little too high and others a little too low.  
Click on the calculator icon on the tool bar or press F9 again to create a solution with Test 
Points. You may be notified that a valid solution exists and asked if you want to resolve. Click 
on No for using that solution to calculate new heads at the test points. 
  
Note: At test point locations where the modeled head exceeds the observed head a green 
triangle points upward, its size proportional to the head difference. The head difference may 
also be posted next to the triangle. Similarly, when the modeled head is lower than the 
observed head a brown triangle points down. You can modify the scale of the triangle, display 
numbers only, or display triangles only. To do so point at Test Points on the View menu and 
check As Text or pointing at As Symbols check +/-5, +/-10, or +/-20 for making the maximum 
triangle size correspond to 5, 10, or 20 feet, respectively. 
  
Pathlines 
Follow these steps to display pathlines toward the well: 

Select Model>Settings>Tracing and check the Compute Particle Paths box. 
Set the Maximum Travel Time to 3650 (10 years).  
Make sure the Use Default Step Size of box is checked. 
Click OK. 
Click on the calculator icon to rerun the solver. If you are notified that a valid solution 
exists, go ahead and use it by clicking on No.  

  
The base map has now an extra overlay: 16 red path lines that converge on the well. Water 
from the end points of these path lines will travel on average 10 years (3650 days) to arrive at 
the well.  
To add time markers to the pathlines select View>Pathlines>Time-of-Travel Tics, and click on 
Every 5 years. 
The map will be redrawn with markers on the path lines from which the water takes 5 years or 
10 years to arrive at the well. You may have to zoom in a little to get a good picture. Use the 
Zoom to Window option on the Window menu and drag a window box with the path lines at its 
center. 
  
Note 1: The accuracy of the path lines and time tics depends on the step size (in feet or meters) 
during the tracing procedure. The default step size depends in turn on the size of the window. If 
you reduce the window, a new path line trace will generate more accurate results. Reducing the 
step size below the default will further increase accuracy, but will also slow down the tracing 
procedure. 
  
Note 2: You may find that some path lines cross the line-sinks along Wabash River. What 
happens is this. The well forces some of the line-sinks opposite the well to infiltrate water into 
the aquifer, while elsewhere Wabash River is receiving water. Particle traces end at such 
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loosing river sections, while elsewhere they cross the river. Additional model refinement may be 
necessary by adding resistance to the line-sinks, see also Editing the Model or Surface water and 
groundwater Interaction  
  
Inspecting model input and output at a point in the domain.  
During the modeling activities it is often useful to know one or more parameters at a particular 
point in the flow domain. For instance, you may want to know what the specified hydraulic 
conductivity or aquifer base elevation is at a point. Or you may want to know what the 
calculated head or groundwater velocity is at that point. GFLOW allows you quick access to 
these data as follows.  
Move the cursor to the point in question and hold down the Shift key while clicking the left 
mouse button. The Solver will be launched to generate all relevant input and output data at that 
location, which will be displayed in a data box on the screen. You may repeat this procedure at 
any point in the domain. Note 1: The reported recharge rate is the sum of all infiltration and 
extraction rates specified at the point in question (e.g. due to nested inhomogeneity domains).  
Note 2: The default elevation for which the data is being reported is at the saturated aquifer top. 
You may select another elevation by clicking on the Instant Inspector SettingsÖ  option on the 
Tools menu. 
  
Creating an instant path line.  
You may also create an instant path line from any point in the domain without creating a new 
particle and recalculating all contours and path lines. Just point at the desired starting point, 
hold down the Ctrl-Shift keys and left-click the mouse. The path line will have the same time of 
travel setting as all other traces. The starting elevation and direction of the instant trace can be 
set under the Instant Inspector SettingÖ  option on the Tools menu. In using this feature you 
have not created a new particle, thus the trace will not be repeated in subsequent contouring 
and particle tracing. 
  
Main Menu            Previous            Next  
Editing the Model 
  
You may change any or all input data items. Aquifer properties can be changed under the 
Aquifer tab on the Model menu by typing over the data in the boxes. If you open the Aquifer tab 
and decide not to make a change, use the Cancel option to leave the Model menu, otherwise 
the program will assume you made a change and will prompt you to create a new solution.  
You may also change aquifer properties locally by defining inhomogeneity domains with 
differing hydraulic conductivity, aquifer base elevation, porosity and areal recharge rate. Note: 
the Inhomogeneity dialog box shows an Added Recharge Rate box, which indicates that the 
recharge rates defined for nested inhomogeneities are cumulative. To add about 1 inch per year 
of recharge you should enter 0.000228 (ft/day) in that box. 

Note: Inhomogeneity domains with a change in the base elevation under unconfined 
conditions result in a non-linear set of equations. You must select at least 3 to 5 
iterations on Model>Settings>Solver before clicking on the calculator icon to solve the 
model. 

  
You may change the location or properties of wells and line-sinks as follows. 

Click on the well or a line-sink vertex in the string you want to edit. The well or line-sink 
string will become highlighted (red).  
Click on the Edit menu and select Properties, Move, Delete, or Refine. 
For line-sinks, when you click on Delete, you will be asked whether you want to delete 
only the selected vertex or the entire string.  
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When selecting Refine, a vertex is added midway in the line-sink on either side of the 
vertex that was selected.  

If all you want to do is change Properties, you may access the Properties dialogue box directly 
by double clicking on the well or a line-sink string vertex. 
  
Refining line-sink strings 
Let's refine the line-sink distribution opposite the well.  

Click on a vertex of the line-sink string for Wabash River close to the well. 
Click on Refine on the Edit menu. Notice the two added vertices (dots) on either side of 
the vertex you clicked on.  
Repeat this for one or two other vertices of the Wabash River line-sink string near the 
well.  
Rerun the solver by clicking on the calculator icon. You may not see much difference, 
depending on the quality of your original line-sink representation of Wabash River.  

Note: Instead of going to the Edit menu, you may also go to the toolbar and click on the Refine 

string icon . 
  
Moving vertices 
You may move one or more vertices on line-sink strings to improve the distribution or change 
the shape of the polyline. 

Click on the vertex you want to move. It will become red. 
Click on Edit>Move and place the plus sign on the new vertex location. 
Left click and the line-sink string will be adjusted. 

Note: Instead of going to the Edit menu, you may also go to the toolbar and click on the Move 
Vertex icon  . 
  
  
Adding resistance to line-sinks 
Another way to improve on the realism of representing Wabash River (and other streams in the 
near-field) is to include an appropriate resistance to flow from the aquifer into the river (or vice 
versa). To do so follow these steps: 

Left click on a vertex of the line-sink string that is to be given resistance. 
If needed uncheck the box Treat as "far-field" on the line-sink dialog box.  
Enter the Resistance, which is defined as the thickness of the resistance layer (silt on the 
river bottom or clay layer underneath the river) divided by the (vertical) conductivity of the 
resistance layer.  
We have earlier entered an estimate of the actual width of Wabash River: 500 feet. We 
entered line-sinks on both sides of the river. Consequently, check under Linesink 
Location the radio button "Along surface water boundary," if not already done. The Solver 
will automatically calculate an "effective leakage zone" and replace the width parameter 
by that zone during the solution process. To understand this concept of an "effective 
leakage zone" read the document "Dealing with resistance to flow into surface 
waters.pdf" in the document folder or for a summary click here. 
The Depth parameter specifies the approximate distance between the surface water 
elevation in the stream and the bottom of the resistance layer underneath the stream. 
This will be an estimated average value for the entire line-sink string. 

Note 1: Line-sinks with resistance under unconfined flow conditions result in a non-linear set of 
equations. You must select at least 3 to 5 iterations on Model>Settings>Solve. 
Note 2: Line-sinks with resistance will correctly show a different CalculatedHead and 
SpecifiedHead in the Results Table on the Model menu. To verify the accuracy of the solution 
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for these line-sinks refer to the Error column (last column), which reports the difference in the 
actual line-sink extraction rate and the calculated rate based on applying Darcy's law across the 
resistance layer. 
Note 3: It is important to never add Resistance, Width and Depth to line-sinks in the far-field.  
This will lead to unstable and inaccurate solutions. To avoid this, always check the box Treat as 
"far-field" when a line-sink string occurs in the far-field.  
Note 4: When all three parameters Resistance, Width and Depth are specified as zero, the line-
sink string must get the Treat as "far-field" box checked.  
Note 5: When assigning a zero Resistance, but a finite Width (and optionally Depth) the line-
sink source density (when it is a loosing line-sink) will be limited to the aquifer hydraulic 
conductivity. This is consistent with the case of incipient ponding in the stream. 
Note 6: The width parameter in the Model Results table or on the Line-sink Information panel 
(which comes up after selecting a line-sink and right-clicking) reflects the "effective leakage 
zone" calculated by the Solver (if resistance is larger than zero). It differs, therefore, from the 
value shown on the Linesink String Properties dialog that is the actual surface water width. 
  
Conjunctive surface water and groundwater modeling 
GFLOW also supports stream flow routing (at least in a simplified fashion). To do so decide 
which strings of line-sinks you want to assemble in a stream network. One of these strings must 
be the End Stream, which is the most downgradient line-sink string where the network ends. To 
declare a line-sink string as part of a stream network you must first declare that line-sink string 
is a near-field feature by unchecking the box Treat as "far-field" on the line-sink dialog box 
(enter the dialog box by right-clicking on a vertex in the string). Make sure you only uncheck 
that box when the line-sink string actually occurs in the near-field. Next select the Routing tab 
sheet of the Line-sink String Properties menu. Check the box for Use streamflow routing . Only 
when this line-sink string is the most down-stream string in the stream network (or the only 
string) check the box End Stream. 
For now leave the Overland Flow and End Inflow values at zero. Repeat this for all strings in the 
network.  
Note: You must have at least one End Stream.  
The solver will automatically assemble the line-sink strings into a stream network and keep 
track of base flow in the streams by adding groundwater inflow. In case a stream section tends 
to loose more water than available as base flow, the infiltration rate is limited to the available 
amount of water. In case the stream is dry, the line-sinks are removed from the groundwater 
flow problem.  
  
You can refine this surface water solution by allowing for an average overland inflow. The 
Overland Flow on the Routing tab of Linesink String Properties is defined as a total volume of 
water (cubic feet per day or cubic meters per), which will be evenly distributed over the line-sink 
string. Note: Overland flow does not have to be Hortonian overland flow, but may represent 
seepage into the stream from saturated or partially saturated formations above the regional 
aquifer. You can also provide the stream with a starting stream flow, for instance from an up 
gradient stream section that is not included in the model. This is done using the End Inflow box 
with units of cubic feet per day or cubic meters per day. The End Inflow is added to the base 
flow of the up gradient line-sink in the line-sink string.  
  
Keep in mind that the conjunctive surface water groundwater solutions only deal with average 
stream flow and groundwater flow (steady state model). Also, the river stage remains the same 
at all times (equal to specified water levels for the line-sink strings), regardless of the stream 
flow. These conjunctive solutions are most valuable for improving the realism of the 
groundwater flow solution, although the average base flows in the model can be helpful in 
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calibration, particularly to estimate the areal recharge rate due to precipitation. 
Note 1: Conjunctive surface water and groundwater problems result in a non-linear set of 
equations. You must select at least 6 to 8 iterations on Model>Settings>Solver. 
Note 2: Line-sink strings in stream networks should be assigned some appropriate Resistance. 
Without any resistance (resistance equal to zero) these line-sinks may show excessive changes 
in infiltration or extraction rates between iterations. This may prevent convergence of the 
solution procedure. 
Note 3: Never create stream networks that extend into the far-field! This will lead to unstable 
and inaccurate solutions. 
Note 4: The conjunctive groundwater and surface water solution procedure has only converged 
when there are no error reports for the surface water solution and sufficiently small errors 
(usually less than a percent) at boundary conditions for the groundwater solution. These errors 
are reported in the DOS box during the solver operation and may be reviewed by opening the 
Runtime Message File under the View Model Run Files option on the Model menu.  
Note 5: Under some circumstances it may be necessary to accept small residual negative 
stream flows when a conjunctive solution fails to converge, even after many iterations. Under 
these circumstances some line-sinks with resistance are also likely to show relatively large 
errors.  
Note 6: Large errors in line-sinks with resistance may be caused by a few line-sinks with very 
small extraction or recharge rates. These errors may be ignored. 
Note 7: You place a Test Point of type Gage next to a line-sink in the stream network where the 
average stream flow or base flow is know, for instance at a USGS stream gage. 
Note 7: For large stream networks an under-relaxation parameter may be needed to achieve 
convergence, see the Advanced button on the Model>Settings>Solver tab behind the options 
Conjunctive Surface Water - Groundwater Solution. 
  
Main Menu            Previous            Next  
Extracting a MODFLOW model 
  
GFLOW facilitates the extraction of a MODFLOW model covering all or part of the model area 
in GFLOW. This may be done as follows. 

Zoom out to the area you want to include in the MODFLOW model and click on 
Linesink Vertices on the View menu.  

Click on GRID and click on Show Grid Dialog.  
Click on File on the Finite Difference Grid dialog box.  
Click on New Grid.  
Specify the number of rows, columns, grid spacing, etc. as indicated on the dialog box. 
Note: the Lower Left X and Lower Left Y will be automatically defined when you create 
the grid on the graphics screen, leave the 0.0 unchanged. Also note that the Row 
Spacing and Column Spacing are in feet if your Computational Units are in feet. 
The Perimeter box is either Head Specified or Discharge Specified, which refers to the 
conditions defined on the grid perimeter. These conditions (heads or discharges) will be 
extracted from the GFLOW solution in a later step. If you select Discharge Specified the 
heads in the MODFLOW model along the grid perimeter must remain close to the current 
heads in the GFLOW model, or the (modified) MODFLOW model is not compatible 
anymore with the original GFLOW model. This may be the case when changing pumping 
rates or recharge rates in the MODFLOW model. In that event a new MODFLOW model 
must be extracted with the modified data implemented in the GFLOW model. 
The Rotation parameter defines the rotation of the grid counter-clock wise in degrees. 
Once you click on Create Grid the grid perimeter will show up with the lower left corner at 
the cursor. Move the grid in place and click. The parameter boxes on the Grid tab will 
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now be disabled.  
To change the defaults on the grid layers, click on the Layers tab. Remember that 
MODFLOW numbers layers from the top down.  
For further changes to the grid parameters select the Edit option on the Finite Difference 
Grid dialog box.  
To verify the grid data select the Tracking tab and move the cursor to the desired grid 
cells for a review of the data.   Note: At this point make sure that no line-sinks straddle 
the grid perimeter. This is why you turned on the Linesink Vertices on the View menu. If 
line-sinks do straddle the grid perimeter, move the nearest vertex to the grid boundary or 
add vertices (using the refine option) and then move the nearest vertex to the grid 
boundary. 
Next click on Processing and click on Apply Analytic Elements to transfer the GFLOW 
boundary conditions to the MODFLOW grid.  
Make sure a valid solution exists (Solve at this point if necessary).  
Select Extract GFLOW Results, to transfer the aquifer data and calculated heads and 
discharges to the MODFLOW grid. 
Finally click on Make MODFLOW files to write a set of MODFLOW input files. 

  
You can import the MODFLOW data files in any MODFLOW preprocessor for further 
manipulation and for running MODFLOW.  
   Note: The MODFLOW files do not include the porosity data of GFLOW (MODFLOW does not 
use these data). However, when conducting particle tracking, for instance with MODPATH, the 
porosity values are needed. Make sure that the proper porosity values are set in your 
MODFLOW/MODPATH preprocessor for accurate travel time calculations during particle 
tracking. This may require you to manually set the porosity in different zones. GFLOW cannot 
do this for you because, as said, MODFLOW data files do not contain the porosity. 
  
Main Menu            Previous            Next  
Printing Graphics 
  
A hard copy of the graphics box may be obtained by sending it to the printer. Open the Project 
menu and select Print Setup. Here you may set margins and select the box "Draw a box at 
picture perimeter". Click OK or Cancel and click on Print for a hard copy of the graphics box. If 
you want to use the default print settings, you may also click on the printer icon on the toolbar. 
  
Main Menu             Previous           Next  
Additional Examples 
  
The directory C:\GFLOW projects \example contains a few more project files to illustrate the 
use of GFLOW. A brief description follows: 
  
  
uniflow.gfl  is an example of the use of uniform flow for the Vincennes capture zone delineation 
modeling represented by the example.gfl project file. You may experiment with changing the 
properties of the uniform flow by selecting Uniform Flow from the Element menu and specifying 
new values (these will replace the existing values). 
  
barrier.gfl is an example of the use of both an open barrier and a closed barrier in the same 
Vincennes model area as used in the tutorial. The analytic element arrangements in barrier.gfl 
differ from the one in example.gfl and the inhomogeneities and barriers are fictitious; they do 
not represent any real geological features in the area. You may experiment with the properties 
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on the barriers (double click a vertex to open the barrier properties dialog box) and with the 
resolution (click on a vertex) and add or delete vertices using the refinement button on the tool 
bar or the delete key, respectively. 
  
two lakes example.gfl is an example of the use of line-sink based lake features, see the 
document "Modeling lake-groundwater interactions in GFLOW.pdf" accessible from the Help 
menu. 
  
highklake.gfl is an example of the use of an inhomogeneity domain to model a lake with a priori 
unknown lake stage, see the document "Modeling lake-groundwater interactions in 
GFLOW.pdf" accessible from the Help menu. 
  
  
The directory C:\GFLOW projects \example2 contains a project file with a complex 
groundwater flow model. 
  
columbus.gfl is an example of a large regional model with several detailed near-field areas. 
The model is being used for capture zone delineation for the well fields of Columbus, Indiana. 
The model features an extensive stream network that is used to assess the impact of current 
and projected groundwater withdrawals on the stream flow in the Columbus area. The 
Columbus.gfl project file is included as a courtesy by WHPA, Inc. and should not be 
commercially used, referenced or published in any form. 
  
columbus-dry.gfl is similar to columbus.gfl, but several wells near a tributary of the East Fork 
of White River have been doubled in pumping rate, which causes sections of that tributary to fall 
dry. 
  
The directory C:\GFLOW projects \validations contains some project files used for validating 
GFLOW. 
  
Uniwell.gfl is a validation problem to test the accuracy of streamline tracing as described in 
Section 1.1 of the document GFLOW1 validations. The exact residence time for a particle along 
a horizontal line through the well, parallel to the regional uniform flow, from a point 200 meters 
up-gradient of the well to a distance of 1 meter from the well axis is 347.95 days. 
  
reisbarrier.gfl is a validation of the horizontal barrier feature in GFLOW. A barrier with 
resistance should be used only when representing a thin wall. The barrier is compared to three 
different discrete representations of the wall, using the inhomogeneity feature in GFLOW. The 
inhomogeneities in the files resisbarrierdiscrete.gfl, resisbarrierdiscrete2.gfl and 
resisbarrierdiscete3.gfl represent walls that are 80 meters long and 10, 5 and 2 meters thick 
respectively. Each of these walls, however, has been given the same resistance of 100 days by 
adjusting the hydraulic conductivity of each wall. The thinner the wall the better the barrier 
feature represents it. When comparing heads and discharges in the domain only the resistance 
of the wall matters. When comparing the residence time across the wall, the wall thickness of 
the barrier must correspond to the wall thickness of the discrete inhomogeneity. The total flux 
through the horizontal barrier in resisbarrier.gfl is 4.7 cubic meters per day. The total flow 
through the corresponding inhomogeneity domains are 6.4, 5.6 and 5.1 for the 10, 5 and 2 
meter thick walls, respectively. The residence times through the horizontal barrier (along a 
streamline through its center) is 21.6 % , 11% and 4.9% higher than through the 10, 5, and 2 
meter wide inhomogeneities, respectively. As is seen from these data, the horizontal barrier 
becomes more accurate the thinner the barrier. 
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circular interface.gfl and coastal interface with well.gfl are validation problems for interface 
flow in GFLOW, see the document "Fresh water and salt water interface flow in GFLOW.pdf"  
  
The folder sectional models contains several cross-sectional models in GFLOW as described 
in the document "Modeling flow in the vertical plane in GFLOW.pdf" 
  
Main Menu            Previous    
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